This is a Demonstration of the new hsgal Feature of the Highslide 4 Joomla Plugin, introduced in version 1.72

How to use ?

I tried to keep this as simple as possible. Just enter this Tag: {hsgal:test} somewhere in your Article / content. The red marked test is the subdirectory where your images for the Gallery are stored in. You have to put it as a subfolder into the existing Joomla Media Directory:

/<your Joomla Site>/images/stories/test

Simple create this Directory by the joomla Media Manager or FTP and upload some images into it. Currently the script supports only png and jpg files, but this should sufficient for now.

Screenshot of my Example Folderscrtucture:
hsgaldir
 


And now the test Sample Gallery :

{hsgal:test}

Amazon Logo Diesen Blog unterstützen?
Bestell dir doch etwas bei Amazon. Nutze diesen speziellen Link, es kostet dich nichts extra und für jeden Kauf darüber erhalte ich eine kleine Gutschrift. Danke!
✉ Marco Götze//

Kommentare

Formate: | Größe: Mb
Anmelden mitoder Benutzernamen eingeben

Tobias
Hallo,ich hab das selbe Problem, die Thumbnails der Gallery werden nicht angezeigt. Auch bei mir liegt Joomla in &amp;#039nem Unterverzeichnis und ich musste wie CG die Zeile 214 anpassen. Aber wie gesagt, die Thumbnails krieg ich nicht hin...Über Hilfe würd ich mich freuen! :-)
Tobias
Hallo,

ich hab das selbe Problem, die Thumbnails der Gallery werden nicht angezeigt. Auch bei mir liegt Joomla in &#039;nem Unterverzeichnis und ich musste wie CG die Zeile 214 anpassen. Aber wie gesagt, die Thumbnails krieg ich nicht hin...

über Hilfe würd ich mich freuen! :-)
Tobias
Hallo,ich hab das selbe Problem, die Thumbnails der Gallery werden nicht angezeigt. Auch bei mir liegt Joomla in 'nem Unterverzeichnis und ich musste wie CG die Zeile 214 anpassen. Aber wie gesagt, die Thumbnails krieg ich nicht hin...Über Hilfe würd ich mich freuen! :-)
CG
I managed to make part of it work by editing line 214 in the sol_highslide.php. Just added .&amp;#039my_joomla_root/&amp;#039 before $pre_dir. That made the ugly links point to the image and also shows the effects, however the thumb still doesn&amp;#039t display and i&amp;#039m wondering if it&amp;#039s the same problem on a different line, i&amp;#039ll try to find it and update through here since the login form to the forum is broken....
CG
I managed to make part of it work by editing line 214 in the sol_highslide.php. Just added .&#039;my_joomla_root/&#039; before $pre_dir. That made the ugly links point to the image and also shows the effects, however the thumb still doesn&#039;t display and i&#039;m wondering if it&#039;s the same problem on a different line, i&#039;ll try to find it and update through here since the login form to the forum is broken....
CG
I managed to make part of it work by editing line 214 in the sol_highslide.php. Just added .'my_joomla_root/' before $pre_dir. That made the ugly links point to the image and also shows the effects, however the thumb still doesn't display and i'm wondering if it's the same problem on a different line, i'll try to find it and update through here since the login form to the forum is broken....
Kevin Douglas
The thumbnail doesn&amp;#039t show.. only the file name. How can fix this?
Kevin Douglas
The thumbnail doesn&#039;t show.. only the file name. How can fix this?
Kevin Douglas
The thumbnail doesn't show.. only the file name. How can fix this?
Alejandro Mohuanna
J.M. you are right; the path is not complete.
Alejandro Mohuanna
J.M. you are right; the path is not complete.
J.M. Stoorvogel
Hi there,thanx for reply! I think I should elaborate. I used an directory in say /home/www/test/blog, and made Apache point to it as http://root/ablog with a virtual host directive.In that case it failed. The plugin never knew it had to prefix with "ablog". By using JURI::base as a prefix, it worked fine!!!Am I allowed to make those modifications?And now you are so willingly to answer, I believe it isn&amp;#039t possible to so some overrides using the {hsgal:xxx} tag, like the width, number of columns, quality, etc, correct?Perhaps you would like me to make those adjustments and send you a copy for a new release or something? It&amp;#039s a nice piece of work and really adds value to one&amp;#039s site.You can mail me directly, the emailadress is valid. You can speak in German too.
J.M. Stoorvogel
Hi there,

thanx for reply! I think I should elaborate. I used an directory in say /home/www/test/blog, and made Apache point to it as http://root/ablog with a virtual host directive.

In that case it failed. The plugin never knew it had to prefix with &quot;ablog&quot;. By using JURI::base as a prefix, it worked fine!!!

Am I allowed to make those modifications?

And now you are so willingly to answer, I believe it isn&#039;t possible to so some overrides using the {hsgal:xxx} tag, like the width, number of columns, quality, etc, correct?

Perhaps you would like me to make those adjustments and send you a copy for a new release or something? It&#039;s a nice piece of work and really adds value to one&#039;s site.

You can mail me directly, the emailadress is valid. You can speak in German too.
J.M. Stoorvogel
Hi there,thanx for reply! I think I should elaborate. I used an directory in say /home/www/test/blog, and made Apache point to it as http://root/ablog with a virtual host directive.In that case it failed. The plugin never knew it had to prefix with "ablog". By using JURI::base as a prefix, it worked fine!!!Am I allowed to make those modifications?And now you are so willingly to answer, I believe it isn't possible to so some overrides using the {hsgal:xxx} tag, like the width, number of columns, quality, etc, correct?Perhaps you would like me to make those adjustments and send you a copy for a new release or something? It's a nice piece of work and really adds value to one's site.You can mail me directly, the emailadress is valid. You can speak in German too.
★Marco Gö†ze
Hmm it&amp;#039s actualy not neccesary to have it in the root, my previous Joomla installe (where I programmed this plugin at) was located in /www/misc/solariz/ hsgal works without any problems in this path.
J.M. Stoorvogel
Hi there,nice work but in order for the gallery to work, Joomla needs to be installed in the root of the webserver. This is not always the case.You should probably patch sol_highslide.php, ( somewhere around) line no 198, $PRE_DIR should include JURI::BASE, as does $thump_script.I am working on this now but somehow it doesn&amp;#039t work yet `-(
solariz
Hmm it&#039;s actualy not neccesary to have it in the root, my previous Joomla installe (where I programmed this plugin at) was located in /www/misc/solariz/ hsgal works without any problems in this path.
★Marco Gö†ze
Hmm it's actualy not neccesary to have it in the root, my previous Joomla installe (where I programmed this plugin at) was located in /www/misc/solariz/ hsgal works without any problems in this path.
J.M. Stoorvogel
Hi there,

nice work but in order for the gallery to work, Joomla needs to be installed in the root of the webserver. This is not always the case.

You should probably patch sol_highslide.php, ( somewhere around) line no 198, $PRE_DIR should include JURI::BASE, as does $thump_script.

I am working on this now but somehow it doesn&#039;t work yet `-(
J.M. Stoorvogel
Hi there,nice work but in order for the gallery to work, Joomla needs to be installed in the root of the webserver. This is not always the case.You should probably patch sol_highslide.php, ( somewhere around) line no 198, $PRE_DIR should include JURI::BASE, as does $thump_script.I am working on this now but somehow it doesn't work yet `-(